Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.





Pages: 1 [2]
Author Topic: SVN not working
EHeM
Advanced
Posts: 56
Permalink
Post Re: SVN not working
on: March 8, 2016, 09:05
Quote

Oh gawd. What I found is rather horrid. The URLs for cloning aren't genuine git repositories, they're some flavor of partial copies of the Subversion repository. Notably, even though ones exist for the branches, those branches lack most of the history and are therefore badly broken for our purposes. As if that wasn't enough, the git copies are named by the release date, not the branch name; ie "15.05" instead of "chaos_calmer".

OpenWRT currently has no generally useful public repository right now, only badly fragmented pieces. I hope they fix it soon, but I might get my alternative working first...

EHeM
Advanced
Posts: 56
Permalink
Post Re: SVN not working
on: June 27, 2016, 23:07
Quote

Not that strictly related, but related to the state of the upstream build trees.

OpenWRT has been forked, there is now the LEDE Project. Many of the OpenWRT developers are now behind LEDE, but not quite all. For the moment the developers with LEDE are also trying to keep their OpenWRT trees up to date, but that may not last.

For DebWRT I see two major benefits of switching to LEDE as upstream: First, looks like much of the brain-trust is with LEDE and OpenWRT may fall behind. Second, LEDE appears to be 100% behind git, rather than OpenWRT's halfway Subversion halfway git.

Right now they're mostly similar trees, but I'd advise keeping an eye on LEDE at a minimum since in the future there will need to be a choice to follow one or the other (I'm tentatively inclined to follow LEDE, but future developments may change that).

amain
Administrator
Posts: 222
Permalink
Post Re: SVN not working
on: June 29, 2016, 19:34
Quote

Thanks. I hadn't notided. I think we have to see how and where things will be moving. In general it believe it would be better if all OpenWrt people could find a way to work out any issues that may be there and keep work together. But we'll see what happens.

EHeM
Advanced
Posts: 56
Permalink
Post Re: SVN not working
on: July 1, 2016, 02:27
Quote

I figured. Right now it sounds like the folks behind LEDE are trying to keep things quiet and not cause too much annoyance/controversy. I only found out since I was attempting to draw attention to issue #22537 (it is rather serious even if the damage is limited) and someone mentioned on IRC that it was fixed in LEDE.

They're stating they're trying to depart OpenWRT without doing any damage, but the announcement of the split was mishandled and not done very politically. Person on the OpenWRT side wrote many of the problems being cited were in fact caused by the people who caused the LEDE fork. That doesn't bode well for the future though perhaps by causing the problems, they became better aware how to fix them.

Can't do much about living in interesting times.

Pages: 1 [2]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.027 seconds.